Skip to content

Commit

Permalink
Use Device Tree for RPi screen
Browse files Browse the repository at this point in the history
  • Loading branch information
Tonymac32 authored and jamess-huang committed Jan 9, 2018
1 parent e99e0b4 commit 4575d6f
Show file tree
Hide file tree
Showing 6 changed files with 11 additions and 234 deletions.
11 changes: 11 additions & 0 deletions arch/arm/boot/dts/rk3288-miniarm.dts
Original file line number Diff line number Diff line change
Expand Up @@ -603,6 +603,17 @@

&i2c3 {
status = "okay";

tinker_ft5406: tinker_ft5406@38 {
compatible = "tinker_ft5406";
reg = <0x38>;
};

tinker_mcu: tinker_mcu@45 {
compatible = "tinker_mcu";
reg = <0x45>;
};

};

&i2c4 {
Expand Down
15 changes: 0 additions & 15 deletions arch/arm/mach-rockchip/rockchip.c
Original file line number Diff line number Diff line change
Expand Up @@ -34,18 +34,6 @@
#define RK3288_GRF_SOC_CON2 0x24C
#define RK3288_TIMER6_7_PHYS 0xff810000

static struct i2c_board_info __initdata i2c_devices_tinker_mcu[] = {
{
I2C_BOARD_INFO("tinker_mcu", 0x45),
},
};

static struct i2c_board_info __initdata i2c_devices_tinker_ft5406[] = {
{
I2C_BOARD_INFO("tinker_ft5406", 0x38),
},
};

static void __init rockchip_timer_init(void)
{
if (of_machine_is_compatible("rockchip,rk3288")) {
Expand Down Expand Up @@ -75,9 +63,6 @@ static void __init rockchip_dt_init(void)
rockchip_suspend_init();
of_platform_populate(NULL, of_default_bus_match_table, NULL, NULL);
platform_device_register_simple("cpufreq-dt", 0, NULL, 0);

i2c_register_board_info(3, i2c_devices_tinker_mcu, ARRAY_SIZE(i2c_devices_tinker_mcu));
i2c_register_board_info(3, i2c_devices_tinker_ft5406, ARRAY_SIZE(i2c_devices_tinker_ft5406));
}

static const char * const rockchip_board_dt_compat[] = {
Expand Down
10 changes: 0 additions & 10 deletions drivers/miniarm/dsi/Kconfig
Original file line number Diff line number Diff line change
Expand Up @@ -7,16 +7,6 @@ config DRM_PANEL_TOSHIBA_TC358762
Say Y here if you want to enable support for toshiba tc358762 bridge.
To compile this driver as a module, choose M here.

config ASUS_RPI_MCU
tristate "RPI MCU for ASUS"
depends on DRM_ROCKCHIP && DRM_PANEL_TOSHIBA_TC358762
depends on I2C
select RPI_MCU
help
This selects support for TOSHIBA TC358762 bridge specific
extensions for ASUS rpi. If you want to enable MIPI DSI
on RK3288 based SoC, you should selet this option.

config ROCKCHIP_DW_MIPI_DSI2
tristate "Rockchip specific extensions for Synopsys DW MIPI DSI"
depends on DRM_ROCKCHIP
Expand Down
1 change: 0 additions & 1 deletion drivers/miniarm/dsi/Makefile
Original file line number Diff line number Diff line change
@@ -1,5 +1,4 @@
obj-$(CONFIG_DRM_PANEL_TOSHIBA_TC358762) += panel-toshiba-tc358762.o
#obj-$(CONFIG_ASUS_RPI_MCU) += asus_mcu.o
obj-$(CONFIG_ROCKCHIP_DW_MIPI_DSI2) += dw-mipi-dsi.o
#obj-$(CONFIG_TINKER_MCU) += tinker_mcu.o
obj-$(CONFIG_TOUCHSCREEN_TINKER_FT5406) += tinker_ft5406.o
192 changes: 0 additions & 192 deletions drivers/miniarm/dsi/asus_mcu.c

This file was deleted.

16 changes: 0 additions & 16 deletions drivers/miniarm/dsi/asus_mcu.h

This file was deleted.

0 comments on commit 4575d6f

Please sign in to comment.