Skip to content

Commit

Permalink
Merge branch 'PowerDNS:master' into rec-openwrt-rusttest
Browse files Browse the repository at this point in the history
  • Loading branch information
omoerbeek authored Jun 9, 2023
2 parents 02832c1 + 1813bf2 commit c285dc7
Show file tree
Hide file tree
Showing 54 changed files with 857 additions and 620 deletions.
26 changes: 15 additions & 11 deletions .github/workflows/multi-arch-test-build.yml
Original file line number Diff line number Diff line change
Expand Up @@ -15,10 +15,22 @@ jobs:
fail-fast: false
matrix:
include:
- arch: aarch64_cortex-a53
target: mvebu-cortexa53
runtime_test: true

- arch: arm_cortex-a15_neon-vfpv4
target: armvirt-32
runtime_test: true

- arch: arm_cortex-a9_vfpv3-d16
target: mvebu-cortexa9
runtime_test: false

- arch: i386_pentium-mmx
target: x86-geode
runtime_test: true

- arch: mips_24kc
target: ath79-generic
runtime_test: true
Expand All @@ -35,17 +47,9 @@ jobs:
target: mpc85xx-p1010
runtime_test: false

- arch: aarch64_cortex-a53
target: mvebu-cortexa53
runtime_test: true

- arch: arm_cortex-a15_neon-vfpv4
target: armvirt-32
runtime_test: true

- arch: i386_pentium-mmx
target: x86-geode
runtime_test: true
- arch: riscv64_riscv64
target: sifiveu-generic
runtime_test: false

- arch: x86_64
target: x86-64
Expand Down
3 changes: 2 additions & 1 deletion admin/zabbix/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -12,7 +12,8 @@ PKG_VERSION:=6.2.3
PKG_RELEASE:=3

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://cdn.zabbix.com/zabbix/sources/stable/6.2/
PKG_SOURCE_URL:=https://cdn.zabbix.com/zabbix/sources/stable/$(basename $(PKG_VERSION))/ \
https://cdn.zabbix.com/zabbix/sources/oldstable/$(basename $(PKG_VERSION))/
PKG_HASH:=2be7e57fb33a55fee71480598e317ffa6a8ee5a39639a7e1b42b2ea6872107b5

PKG_MAINTAINER:=Etienne CHAMPETIER <champetier.etienne@gmail.com>
Expand Down
55 changes: 0 additions & 55 deletions devel/packr/Makefile

This file was deleted.

2 changes: 1 addition & 1 deletion lang/golang/golang-values.mk
Original file line number Diff line number Diff line change
Expand Up @@ -201,7 +201,7 @@ endif

# Target Go

GO_ARCH_DEPENDS:=@(aarch64||arm||i386||i686||mips||mips64||mips64el||mipsel||powerpc64||x86_64)
GO_ARCH_DEPENDS:=@(aarch64||arm||i386||i686||mips||mips64||mips64el||mipsel||powerpc64||riscv64||x86_64)


# ASLR/PIE
Expand Down
29 changes: 26 additions & 3 deletions lang/lua-eco/Makefile
Original file line number Diff line number Diff line change
@@ -1,12 +1,12 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=lua-eco
PKG_VERSION:=2.2.0
PKG_VERSION:=2.3.0
PKG_RELEASE:=1

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL=https://github.com/zhaojh329/lua-eco/releases/download/v$(PKG_VERSION)
PKG_HASH:=b45073ba93123d93ab7521b1e699c0f8f8f7de513342b16e2115a0f5a26f8014
PKG_HASH:=931737acd080bd309fd589c521ad32d00b2285fe9edeefdcacb86ba8f1fe1fdc

PKG_MAINTAINER:=Jianhui Zhao <zhaojh329@gmail.com>
PKG_LICENSE:=MIT
Expand Down Expand Up @@ -59,7 +59,10 @@ Package/lua-eco-http=$(call Package/lua-eco/Module,http/https,+lua-eco-dns +lua-
Package/lua-eco-mqtt=$(call Package/lua-eco/Module,mqtt,+lua-eco-socket +lua-eco-dns +lua-mosquitto)
Package/lua-eco-websocket=$(call Package/lua-eco/Module,websocket,+lua-eco-http +lua-eco-base64 +lua-eco-sha1)
Package/lua-eco-termios=$(call Package/lua-eco/Module,termios)
Package/lua-eco-network=$(call Package/lua-eco/Module,network)
Package/lua-eco-struct=$(call Package/lua-eco/Module,struct pack)
Package/lua-eco-network=$(call Package/lua-eco/Module,network utils)
Package/lua-eco-netlink=$(call Package/lua-eco/Module,netlink)
Package/lua-eco-nl80211=$(call Package/lua-eco/Module,nl80211,+lua-eco-netlink)

define Package/lua-eco-ssl/config
choice
Expand Down Expand Up @@ -170,11 +173,29 @@ define Package/lua-eco-termios/install
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/lua/eco/termios.so $(1)/usr/lib/lua/eco
endef

define Package/lua-eco-struct/install
$(INSTALL_DIR) $(1)/usr/lib/lua/eco
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/lua/eco/struct.so $(1)/usr/lib/lua/eco
endef

define Package/lua-eco-network/install
$(INSTALL_DIR) $(1)/usr/lib/lua/eco
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/lua/eco/network.so $(1)/usr/lib/lua/eco
endef

define Package/lua-eco-netlink/install
$(INSTALL_DIR) $(1)/usr/lib/lua/eco/core
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/lua/eco/{nl,genl}.lua $(1)/usr/lib/lua/eco
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/lua/eco/core/{nl,genl}.so $(1)/usr/lib/lua/eco/core
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/lua/eco/rtnl.so $(1)/usr/lib/lua/eco
endef

define Package/lua-eco-nl80211/install
$(INSTALL_DIR) $(1)/usr/lib/lua/eco/core
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/lua/eco/nl80211.lua $(1)/usr/lib/lua/eco
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/lua/eco/core/nl80211.so $(1)/usr/lib/lua/eco/core
endef

$(eval $(call BuildPackage,lua-eco))
$(eval $(call BuildPackage,lua-eco-log))
$(eval $(call BuildPackage,lua-eco-sys))
Expand All @@ -190,3 +211,5 @@ $(eval $(call BuildPackage,lua-eco-mqtt))
$(eval $(call BuildPackage,lua-eco-websocket))
$(eval $(call BuildPackage,lua-eco-termios))
$(eval $(call BuildPackage,lua-eco-network))
$(eval $(call BuildPackage,lua-eco-netlink))
$(eval $(call BuildPackage,lua-eco-nl80211))
12 changes: 9 additions & 3 deletions lang/php8/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -94,7 +94,7 @@ endef

define Package/php8-cli
$(call Package/php8/Default)
DEPENDS+= +PACKAGE_php8-mod-intl:libstdcpp
DEPENDS+= +PACKAGE_php8-mod-intl:libstdcpp +riscv64:libatomic
TITLE+= (CLI)
endef

Expand All @@ -105,7 +105,7 @@ endef

define Package/php8-cgi
$(call Package/php8/Default)
DEPENDS+= +PACKAGE_php8-mod-intl:libstdcpp
DEPENDS+= +PACKAGE_php8-mod-intl:libstdcpp +riscv64:libatomic
TITLE+= (CGI & FastCGI)
endef

Expand All @@ -127,7 +127,7 @@ endef

define Package/php8-fpm
$(call Package/php8/Default)
DEPENDS+= +PACKAGE_php8-mod-intl:libstdcpp
DEPENDS+= +PACKAGE_php8-mod-intl:libstdcpp +riscv64:libatomic
TITLE+= (FPM)
endef

Expand Down Expand Up @@ -159,6 +159,7 @@ define Package/apache-mod-php8
CATEGORY:=Network
DEPENDS+=PACKAGE_apache-mod-php8:apache \
+PACKAGE_php8-mod-intl:libstdcpp \
+riscv64:libatomic \
+libpcre2 +zlib
TITLE:=PHP8 module for Apache Web Server
endef
Expand Down Expand Up @@ -197,6 +198,9 @@ endif
ifeq ($(CONFIG_USE_MUSL),y)
TARGET_CFLAGS += -D_LARGEFILE64_SOURCE
endif
ifneq ($(findstring riscv64,$(CONFIG_ARCH)),)
TARGET_LDFLAGS += -latomic
endif

ifneq ($(SDK)$(CONFIG_PACKAGE_php8-mod-bcmath),)
CONFIGURE_ARGS+= --enable-bcmath=shared
Expand Down Expand Up @@ -603,6 +607,8 @@ define BuildModule
define Package/php8-mod-$(1)
$(call Package/php8/Default)

DEPENDS+=+riscv64:libatomic

ifneq ($(3),)
DEPENDS+=$(3)
endif
Expand Down
115 changes: 99 additions & 16 deletions lang/python/micropython-lib/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -12,42 +12,125 @@ PKG_RELEASE:=1

PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/micropython/micropython-lib.git
PKG_SOURCE_VERSION:=db4c739863e49fc874bdaae8aa8c316c7ed4276a
PKG_SOURCE_DATE:=20220506
PKG_MIRROR_HASH:=ec4be91755fcd4d4fa61e1e7eadc748377ba63b82b7bb4254864473fafcd3173
PKG_SOURCE_VERSION:=7128d423c2e7c0309ac17a1e6ba873b909b24fcc
PKG_SOURCE_DATE:=20230522
PKG_MIRROR_HASH:=1f094aac257d2094ee91b457164f845f6461df1cf1d0ed7ee556c98f273f5afb

PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
PKG_LICENSE:=MIT PSF-2.0
PKG_LICENSE:=MIT Python-2.0.1
PKG_LICENSE_FILES:=LICENSE

PKG_BUILD_DEPENDS:=python3/host
PKG_BUILD_PARALLEL:=1

# keep in sync with micropython
MP_VERSION:=1.20.0
MP_MPY_FILE_VERSION:=6

include $(INCLUDE_DIR)/package.mk

define Package/micropython-lib
define Package/micropython-lib/Default
SUBMENU:=Python
SECTION:=lang
CATEGORY:=Languages
TITLE:=micropython-lib
TITLE:=MicroPython package repository
URL:=https://github.com/micropython/micropython-lib
endef

define Package/micropython-lib
$(call Package/micropython-lib/Default)
DEPENDS:=+micropython
endef

define Package/micropython-lib-src
$(call Package/micropython-lib/Default)
TITLE+= (sources)
endef

define Package/micropython-lib-unix
$(call Package/micropython-lib/Default)
TITLE+= - Unix port packages
DEPENDS:=+micropython +libpcre +librt +libsqlite3
endef

define Package/micropython-lib-unix-src
$(call Package/micropython-lib/Default)
TITLE+= - Unix port packages (sources)
endef

define Package/micropython-lib/Default/description
This is a repository of packages designed to be useful for writing
MicroPython applications.
endef

define Package/micropython-lib/description
This is a repository of libraries designed to be useful for writing
MicroPython applications.
$(call Package/micropython-lib/Default/description)

This contains packages common to all MicroPython ports.
endef

define Package/micropython-lib-src/description
$(call Package/micropython-lib/Default/description)

This contains source files for packages common to all MicroPython ports.
endef

define Package/micropython-lib-unix/description
$(call Package/micropython-lib/Default/description)

This contains packages specific to the MicroPython Unix port.
endef

define Package/micropython-lib-unix-src/description
$(call Package/micropython-lib/Default/description)

This contains source files for packages specific to the MicroPython Unix
port.
endef

MP_INSTALLDEV_PATH:=$(STAGING_DIR)/host/lib/micropython-$(MP_VERSION)

define MicroPythonLib/Compile
cd "$(PKG_BUILD_DIR)" && python3 tools/build.py \
--hash-prefix 64 \
--micropython "$(MP_INSTALLDEV_PATH)" \
--mpy-cross "$(MP_INSTALLDEV_PATH)/mpy-cross/build/mpy-cross" \
--output "$(PKG_BUILD_DIR)/$(strip $(1))" \
$(2)
endef

define MicroPythonLib/Install
python3 install.py \
--input "$(PKG_BUILD_DIR)/$(strip $(1))" \
--output "$(strip $(3))" \
--version "$(strip $(2))"
endef

Build/Compile:=:
define Build/Compile
$(call MicroPythonLib/Compile)
$(call MicroPythonLib/Compile,unix-ffi-index,--unix-ffi)
endef

define Package/micropython-lib/install
for dir in micropython python-ecosys python-stdlib unix-ffi; do \
$(INSTALL_DIR) $(1)/usr/lib/micropython/$$$$dir ; \
$(CP) $(PKG_BUILD_DIR)/$$$$dir/* $(1)/usr/lib/micropython/$$$$dir/ ; \
done
$(FIND) $(1)/usr/lib/micropython \
-not -type d \( -not -name '*.py' -o -name 'test_*' -o -name 'setup.py' \) -delete
$(FIND) $(1)/usr/lib/micropython -mindepth 1 -empty -type d -delete
$(call MicroPythonLib/Install,,$(MP_MPY_FILE_VERSION),$(1)/usr/lib/micropython)
endef

define Package/micropython-lib-src/install
$(call MicroPythonLib/Install,,py,$(1)/usr/lib/micropython)
endef

define Package/micropython-lib-unix/install
$(call MicroPythonLib/Install,unix-ffi-index,$(MP_MPY_FILE_VERSION),$(1)/usr/lib/micropython/unix)

$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) ./files/micropython-unix $(1)/usr/bin/
endef

define Package/micropython-lib-unix-src/install
$(call MicroPythonLib/Install,unix-ffi-index,py,$(1)/usr/lib/micropython/unix)
endef

$(eval $(call BuildPackage,micropython-lib))
$(eval $(call BuildPackage,micropython-lib-src))
$(eval $(call BuildPackage,micropython-lib-unix))
$(eval $(call BuildPackage,micropython-lib-unix-src))
3 changes: 3 additions & 0 deletions lang/python/micropython-lib/files/micropython-unix
Original file line number Diff line number Diff line change
@@ -0,0 +1,3 @@
#!/bin/sh
export MICROPYPATH=".frozen:~/.micropython/lib:/usr/lib/micropython/unix:/usr/lib/micropython"
exec micropython "$@"
Loading

0 comments on commit c285dc7

Please sign in to comment.