Skip to content

Commit d21b83c

Browse files
authored
addpatch: vim-jedi 0.11.2-3 (#4482)
Authored-by: gyx47 <gyx47@github.com>
1 parent 46fe6f5 commit d21b83c

File tree

2 files changed

+45
-0
lines changed

2 files changed

+45
-0
lines changed

vim-jedi/riscv64.patch

+25
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,25 @@
1+
--- PKGBUILD
2+
+++ PKGBUILD
3+
@@ -17,15 +17,19 @@ checkdepends=('python-pytest')
4+
groups=('vim-plugins')
5+
options=('!emptydirs')
6+
source=(https://github.com/davidhalter/${_reponame}/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz
7+
- python-3.13-accept-test-results.patch)
8+
+ python-3.13-accept-test-results.patch
9+
+ test-signature.patch)
10+
sha256sums=('e169429a6a4bce5a32b94a3d7cc784c746f9d4fd78354122895ba50ded867afa'
11+
- '08fe5fd50fac1f5d74ec95defb2411d079e518c396b94d4721105f6d5900099f')
12+
+ '08fe5fd50fac1f5d74ec95defb2411d079e518c396b94d4721105f6d5900099f'
13+
+ '03e03f8a6b2b1ad6fd41034e9aeb0a274f1835ebefcb6a3fcc59a2bde58f2f9e')
14+
b2sums=('375cdf4742eb6328f5dc601b7a0b529a3d18b70711f93ab860e2827275f36454281c9d4ec85de0cfe280115fadde3a45f1bf74bfb4a4f1036b603eaa6051bf56'
15+
- '5c160c31c46cf887a4b20e72b4386ad8c762dd229a469c184257dbc288c56f02fc256fce72cd993dfd7c843d347d55aef55683997449ad9955330adf21270d15')
16+
+ '5c160c31c46cf887a4b20e72b4386ad8c762dd229a469c184257dbc288c56f02fc256fce72cd993dfd7c843d347d55aef55683997449ad9955330adf21270d15'
17+
+ 'd6f2a067ea28a9dd6ae7af010f90a79965f1051a00f1139212ae33d7f38b7b9e7d8c913c4ee5027179fb85fe041e39d7b3c0ea0602382c37e61863b532643a88')
18+
19+
prepare() {
20+
cd ${_reponame}-${pkgver}
21+
patch -Np1 -i ../python-3.13-accept-test-results.patch
22+
+ patch -Np1 -i ../test-signature.patch
23+
}
24+
25+
check() {

vim-jedi/test-signature.patch

+20
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,20 @@
1+
--- a/test/vspec/signatures.vim
2+
+++ b/test/vspec/signatures.vim
3+
@@ -111,7 +111,7 @@ describe 'signatures'
4+
let funcname = repeat('a', &columns - (30 + (&ruler ? 18 : 0)))
5+
put = 'def '.funcname.'(arg1, arg2, arg3, a, b, c):'
6+
put = ' pass'
7+
- execute "normal o\<BS>".funcname."( "
8+
+ execute "normal o".funcname."( "
9+
Expect Signature() == "\n".funcname."(arg1, …)"
10+
11+
exe 'normal sarg1, '
12+
@@ -126,7 +126,7 @@ describe 'signatures'
13+
g/^/d
14+
put = 'def '.funcname.'('.repeat('b', 20).', arg2):'
15+
put = ' pass'
16+
- execute "normal o\<BS>".funcname."( "
17+
+ execute "normal o".funcname."( "
18+
Expect Signature() == "\n".funcname."(…)"
19+
end
20+

0 commit comments

Comments
 (0)