Skip to content

Commit 79257d5

Browse files
committed
[BOT] post-merge updates
1 parent 5be726a commit 79257d5

File tree

6 files changed

+14
-9
lines changed

6 files changed

+14
-9
lines changed

README.md

+1
Original file line numberDiff line numberDiff line change
@@ -46,6 +46,7 @@ addon | version | maintainers | summary
4646
[base_tier_validation_server_action](base_tier_validation_server_action/) | 16.0.1.0.0 | [![kittiu](https://github.com/kittiu.png?size=30px)](https://github.com/kittiu) | Add option to call server action when a tier is validated
4747
[base_tier_validation_waiting](base_tier_validation_waiting/) | 16.0.1.0.0 | | Base Tier Validation Extension to add waiting status
4848
[base_user_locale](base_user_locale/) | 16.0.1.1.0 | | User Locale Settings
49+
[confirmation_wizard](confirmation_wizard/) | 16.0.1.0.0 | | This module adds a confirmation wizard that can be called with code. It does nothing by itself.
4950
[date_range](date_range/) | 16.0.1.0.9 | [![lmignon](https://github.com/lmignon.png?size=30px)](https://github.com/lmignon) | Manage all kind of date range
5051
[date_range_account](date_range_account/) | 16.0.1.0.1 | [![alexis-via](https://github.com/alexis-via.png?size=30px)](https://github.com/alexis-via) | Add Date Range menu entry in Invoicing app
5152
[developer_menu](developer_menu/) | 16.0.1.0.0 | [![bealdav](https://github.com/bealdav.png?size=30px)](https://github.com/bealdav) | Menu Shortcut for developer usage

confirmation_wizard/README.rst

+1-1
Original file line numberDiff line numberDiff line change
@@ -7,7 +7,7 @@ Confirmation Wizard
77
!! This file is generated by oca-gen-addon-readme !!
88
!! changes will be overwritten. !!
99
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
10-
!! source digest: sha256:efcbab8311be7e220ab27fa46f0fcd4567d0ad071dfc40be6e5aece82b96e299
10+
!! source digest: sha256:7c09aec540a642f981c869d8ce3465f373296e5c5f84568e5483476a93c82014
1111
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
1212
1313
.. |badge1| image:: https://img.shields.io/badge/maturity-Beta-yellow.png
Loading

confirmation_wizard/static/description/index.html

+10-7
Original file line numberDiff line numberDiff line change
@@ -8,10 +8,11 @@
88

99
/*
1010
:Author: David Goodger (goodger@python.org)
11-
:Id: $Id: html4css1.css 8954 2022-01-20 10:10:25Z milde $
11+
:Id: $Id: html4css1.css 9511 2024-01-13 09:50:07Z milde $
1212
:Copyright: This stylesheet has been placed in the public domain.
1313
1414
Default cascading style sheet for the HTML output of Docutils.
15+
Despite the name, some widely supported CSS2 features are used.
1516
1617
See https://docutils.sourceforge.io/docs/howto/html-stylesheets.html for how to
1718
customize this style sheet.
@@ -274,7 +275,7 @@
274275
margin-left: 2em ;
275276
margin-right: 2em }
276277

277-
pre.code .ln { color: grey; } /* line numbers */
278+
pre.code .ln { color: gray; } /* line numbers */
278279
pre.code, code { background-color: #eeeeee }
279280
pre.code .comment, code .comment { color: #5C6576 }
280281
pre.code .keyword, code .keyword { color: #3B0D06; font-weight: bold }
@@ -300,7 +301,7 @@
300301
span.pre {
301302
white-space: pre }
302303

303-
span.problematic {
304+
span.problematic, pre.problematic {
304305
color: red }
305306

306307
span.section-subtitle {
@@ -366,7 +367,7 @@ <h1 class="title">Confirmation Wizard</h1>
366367
!! This file is generated by oca-gen-addon-readme !!
367368
!! changes will be overwritten. !!
368369
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
369-
!! source digest: sha256:efcbab8311be7e220ab27fa46f0fcd4567d0ad071dfc40be6e5aece82b96e299
370+
!! source digest: sha256:7c09aec540a642f981c869d8ce3465f373296e5c5f84568e5483476a93c82014
370371
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! -->
371372
<p><a class="reference external image-reference" href="https://odoo-community.org/page/development-status"><img alt="Beta" src="https://img.shields.io/badge/maturity-Beta-yellow.png" /></a> <a class="reference external image-reference" href="http://www.gnu.org/licenses/lgpl-3.0-standalone.html"><img alt="License: LGPL-3" src="https://img.shields.io/badge/licence-LGPL--3-blue.png" /></a> <a class="reference external image-reference" href="https://github.com/OCA/server-ux/tree/16.0/confirmation_wizard"><img alt="OCA/server-ux" src="https://img.shields.io/badge/github-OCA%2Fserver--ux-lightgray.png?logo=github" /></a> <a class="reference external image-reference" href="https://translation.odoo-community.org/projects/server-ux-16-0/server-ux-16-0-confirmation_wizard"><img alt="Translate me on Weblate" src="https://img.shields.io/badge/weblate-Translate%20me-F47D42.png" /></a> <a class="reference external image-reference" href="https://runboat.odoo-community.org/builds?repo=OCA/server-ux&amp;target_branch=16.0"><img alt="Try me on Runboat" src="https://img.shields.io/badge/runboat-Try%20me-875A7B.png" /></a></p>
372373
<p>The module lets the developer trigger a confirmation wizard during any action in Odoo. Based on data passed to the wizard and, based on user input, executes specified methods or close wizard.</p>
@@ -388,7 +389,7 @@ <h1><a class="toc-backref" href="#toc-entry-1">Usage</a></h1>
388389
<p>To create configuration wizard:</p>
389390
<p>Use confirm wizard which return method (return_type = method):</p>
390391
<pre class="code python literal-block">
391-
<span class="k">def</span> <span class="nf">change_address</span><span class="p">(</span><span class="bp">self</span><span class="p">,</span> <span class="n">address</span><span class="p">):</span><span class="w">
392+
<span class="k">def</span><span class="w"> </span><span class="nf">change_address</span><span class="p">(</span><span class="bp">self</span><span class="p">,</span> <span class="n">address</span><span class="p">):</span><span class="w">
392393
</span> <span class="c1"># Confirmation wizard</span><span class="w">
393394
</span> <span class="n">action</span> <span class="o">=</span> <span class="p">(</span><span class="w">
394395
</span> <span class="bp">self</span><span class="o">.</span><span class="n">env</span><span class="p">[</span><span class="s2">&quot;confirmation.wizard&quot;</span><span class="p">]</span><span class="w">
@@ -406,7 +407,7 @@ <h1><a class="toc-backref" href="#toc-entry-1">Usage</a></h1>
406407
</pre>
407408
<p>Use confirm wizard which does nothing and closes itself when clicking confirm (return_type = window_close):</p>
408409
<pre class="code python literal-block">
409-
<span class="k">def</span> <span class="nf">method</span><span class="p">(</span><span class="bp">self</span><span class="p">):</span><span class="w">
410+
<span class="k">def</span><span class="w"> </span><span class="nf">method</span><span class="p">(</span><span class="bp">self</span><span class="p">):</span><span class="w">
410411
</span> <span class="o">...</span><span class="w">
411412
</span> <span class="k">return</span> <span class="p">(</span><span class="w">
412413
</span> <span class="bp">self</span><span class="o">.</span><span class="n">env</span><span class="p">[</span><span class="s2">&quot;confirmation.wizard&quot;</span><span class="p">]</span><span class="w">
@@ -452,7 +453,9 @@ <h2><a class="toc-backref" href="#toc-entry-5">Contributors</a></h2>
452453
<div class="section" id="maintainers">
453454
<h2><a class="toc-backref" href="#toc-entry-6">Maintainers</a></h2>
454455
<p>This module is maintained by the OCA.</p>
455-
<a class="reference external image-reference" href="https://odoo-community.org"><img alt="Odoo Community Association" src="https://odoo-community.org/logo.png" /></a>
456+
<a class="reference external image-reference" href="https://odoo-community.org">
457+
<img alt="Odoo Community Association" src="https://odoo-community.org/logo.png" />
458+
</a>
456459
<p>OCA, or the Odoo Community Association, is a nonprofit organization whose
457460
mission is to support the collaborative development of Odoo features and
458461
promote its widespread use.</p>

setup/_metapackage/VERSION.txt

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
16.0.20250120.0
1+
16.0.20250225.0

setup/_metapackage/setup.py

+1
Original file line numberDiff line numberDiff line change
@@ -33,6 +33,7 @@
3333
'odoo-addon-base_tier_validation_server_action>=16.0dev,<16.1dev',
3434
'odoo-addon-base_tier_validation_waiting>=16.0dev,<16.1dev',
3535
'odoo-addon-base_user_locale>=16.0dev,<16.1dev',
36+
'odoo-addon-confirmation_wizard>=16.0dev,<16.1dev',
3637
'odoo-addon-date_range>=16.0dev,<16.1dev',
3738
'odoo-addon-date_range_account>=16.0dev,<16.1dev',
3839
'odoo-addon-developer_menu>=16.0dev,<16.1dev',

0 commit comments

Comments
 (0)