Commit 884f003 1 parent 7fc0fce commit 884f003 Copy full SHA for 884f003
File tree 5 files changed +16
-5
lines changed
5 files changed +16
-5
lines changed Original file line number Diff line number Diff line change 1
1
# Do NOT update manually; changes here will be overwritten by Copier
2
- _commit : v1.17.2
2
+ _commit : v1.21.1
3
3
_src_path : gh:oca/oca-addons-repo-template
4
4
ci : GitHub
5
+ convert_readme_fragments_to_markdown : false
5
6
generate_requirements_txt : true
6
7
github_check_license : true
7
8
github_ci_extra_env : {}
@@ -19,4 +20,6 @@ repo_description: Modules for handling various authentication schemes
19
20
repo_name : Server Authentication
20
21
repo_slug : server-auth
21
22
repo_website : https://github.com/OCA/server-auth
23
+ use_pyproject_toml : false
24
+ use_ruff : false
22
25
Original file line number Diff line number Diff line change 9
9
runs-on : ubuntu-latest
10
10
steps :
11
11
- name : Stale PRs and issues policy
12
- uses : actions/stale@v4
12
+ uses : actions/stale@v9
13
13
with :
14
14
repo-token : ${{ secrets.GITHUB_TOKEN }}
15
15
# General settings.
48
48
# * Issues that are pending more information
49
49
# * Except Issues marked as "no stale"
50
50
- name : Needs more information stale issues policy
51
- uses : actions/stale@v4
51
+ uses : actions/stale@v9
52
52
with :
53
53
repo-token : ${{ secrets.GITHUB_TOKEN }}
54
54
ascending : true
Original file line number Diff line number Diff line change 63
63
run : oca_init_test_database
64
64
- name : Run tests
65
65
run : oca_run_tests
66
- - uses : codecov/codecov-action@v1
66
+ - uses : codecov/codecov-action@v4
67
+ with :
68
+ token : ${{ secrets.CODECOV_TOKEN }}
67
69
- name : Update .pot files
68
70
run : oca_export_and_push_pot https://x-access-token:${{ secrets.GIT_PUSH_TOKEN }}@github.com/${{ github.repository }}
69
71
if : ${{ matrix.makepot == 'true' && github.event_name == 'push' && github.repository_owner == 'OCA' }}
Original file line number Diff line number Diff line change @@ -3,6 +3,7 @@ __pycache__/
3
3
* .py [cod ]
4
4
/.venv
5
5
/.pytest_cache
6
+ /.ruff_cache
6
7
7
8
# C extensions
8
9
* .so
Original file line number Diff line number Diff line change @@ -16,6 +16,10 @@ exclude: |
16
16
^docs/_templates/.*\.html$|
17
17
# Don't bother non-technical authors with formatting issues in docs
18
18
readme/.*\.(rst|md)$|
19
+ # Ignore build and dist directories in addons
20
+ /build/|/dist/|
21
+ # Ignore test files in addons
22
+ /tests/samples/.*|
19
23
# You don't usually want a bot to modify your legal texts
20
24
(LICENSE.*|COPYING.*)
21
25
default_language_version :
37
41
language : fail
38
42
files : ' [a-zA-Z0-9_]*/i18n/en\.po$'
39
43
- repo : https://github.com/oca/maintainer-tools
40
- rev : 969238e47c07d0c40573acff81d170f63245d738
44
+ rev : 9a170331575a265c092ee6b24b845ec508e8ef75
41
45
hooks :
42
46
# update the NOT INSTALLABLE ADDONS section above
43
47
- id : oca-update-pre-commit-excluded-addons
50
54
- --org-name=OCA
51
55
- --repo-name=server-auth
52
56
- --if-source-changed
57
+ - --keep-source-digest
53
58
- repo : https://github.com/OCA/odoo-pre-commit-hooks
54
59
rev : v0.0.25
55
60
hooks :
You can’t perform that action at this time.
0 commit comments