日期 2021 / 10 / 20
[题目链接]https://acm.dingbacode.com/showproblem.php?pid=1027
Problem Description Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."
"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......" Can you help Ignatius to solve this problem?
Input
The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.
Output
For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.
Sample Input
6 4
11 8
Sample Output
1 2 3 5 6 4
1 2 3 4 5 6 7 9 8 11 10
给定n个数字,从1到n,要求输出第m小的序列
我们知道STL里面提供了一个下一个排列组合的函数next_permutation,这个函数是利用了全排列中按字典序进行排列并求出下一> 个排列序列如果存在排列返回true否则返回false,例如abcd的下一个排列是abdc,同样的还有prev_permutation这个函数,这个是求上一个排列序列,所以我们可以> 利用这一点求出答案,要求第m个小的话利用do while循环遍历到第m个并输出.
#include <bits/stdc++.h>
#define INF 0x7fffffff
#define rep(x, y, z) for (int x = y; x <= z; x++)
#define dec(x, y, z) for (int x = y; x >= z; x--)
#define format(a) memset (a, 0, sizeof(a))
#define swap(a, b) (a ^= b ^= a ^= b)
#define ll long long int
#define ull unsigned long long int
#define uint unsigned int
const int maxn = 1e6 + 10;
using namespace std;
int a[1010];
int main(int argc, char *argv[]) {
ios_base::sync_with_stdio(false);
cin.tie(nullptr);
int n, m;
while (cin >> n >> m) {
for (int i = 1; i <= n; i++) {
a[i] = i;
}
int k = 1;
do {
if (k == m) {
break;
}
k++;
} while (next_permutation(a + 1, a + n + 1));
for (int i = 1; i < n; i++) {
cout << a[i] << ' ';
}
cout << a[n] << endl;
}
return 0;
}